Mails are delayed
Incident Report for Statuspage Billwerk
Resolved
The incident is resolved
Posted Jan 15, 2024 - 15:13 CET
Investigating
We have a problem with the sending of E-Mails. There might be delays
Posted Jan 15, 2024 - 13:46 CET
This incident affected: app.billwerk.com.